PHP4.4.6和Mysql 5.0兼容性

这次有台Windows服务器拿到手中,需要装AMP,我一激进,装了Apache2.2.4 + Php5.2.1 + mysql-5.0.37。事后发现,网站程序用PHP4写的,和PHP5.2.1有点兼容性问题,于是乎换装PHP4,发现PHP4没有Apache2.2的模块,只好用CGI方式安装。接下来程序运行报错数据库无法连接,猜测是php4的mysql扩展不兼容mysql5。在网上找了半天,发现有老外自己编译了一个php4.4.6的补丁,下载覆盖了原来的dll文件,然后便成功了,特此备忘。

《PHP4.4.6和Mysql 5.0兼容性》上有1条评论

  1. What i don’t understood is in reality how you are no longer really much more well-favored than you might be now.
    You are very intelligent. You realize thus significantly in terms of this topic, made me individually believe it from numerous numerous angles.
    Its like women and men aren’t involved unless it’s one thing to do
    with Girl gaga! Your individual stuffs outstanding.
    All the time maintain it up!

发表评论

电子邮件地址不会被公开。 必填项已用*标注

This site uses Akismet to reduce spam. Learn how your comment data is processed.